Forum issues are discussed here

Discussion, questions and suggestions about Lejonklou products

Moderator: Staff

Spannko
Very active member
Very active member
Posts: 1097
Joined: 2008-01-24 21:46
Location: East of The Black Country, UK

Re: Forum issues are discussed here

Post by Spannko » 2018-11-12 15:02

I’m getting lots of php debug warnings in file root.

Also, is there a problem with PMs?

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2018-11-12 20:39

Forum was down for most of today, for a series of unfortunate events and some neglect on my part.

Expect some more downtime during the next 24 hours, as updates, fixes and repairs need to be done. Please be aware there's a risk that any new posts that you publish can become lost during this period.

Sorry for the inconvenience!!

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2018-11-13 02:39

Forum is now back online. Apologies for the long offline period today!

Unfortunately, the old style (design) is incompatible with the latest version of this forum software and the latest version is vital for everything to run properly. Designing a new style is quite a challenge (well, for me at least) and very time consuming, as it needs to be compatible with all browsers and screen sizes.

Therefore I've just made some basic changes to a standard theme. I apologise if you think it looks terrible, but I will need external help to properly customise the appearance. My web guy, who designed the old forum, has changed to a new job and can't help me. For the time being, this will have to do.

If you have any suggestions regarding who can make this forum look better, I would be grateful!

If you have any suggestions regarding the design and appearance, please make notes and save them for later! Please don't post such suggestions right here and now, because I currently need to focus on some electronic circuits I have on my workbench.

If some parts or features of the forum don't work properly, please do report them here and I'll do my best to fix them.

Thank you for your understanding!

macrotech2
Very active member
Very active member
Posts: 296
Joined: 2012-04-27 07:58

Re: Forum issues are discussed here

Post by macrotech2 » 2018-11-13 09:46

I like the new look! Thanks for all the hard work Fredrik.

I have a bookmark set to new posts which still shows the topics with new posts, but I can’t see how to go direct to the new posts any more.
KDS/3 Katalyst / Oppo 205 / Sky Q / Sagatun Mono Tarandus / Tundra Mono 2 Tarandus / Akubariks

jewa
Active Member
Active Member
Posts: 77
Joined: 2007-01-31 18:57

Re: Forum issues are discussed here

Post by jewa » 2018-11-13 09:52

macrotech2 wrote:
2018-11-13 09:46
I have a bookmark set to new posts which still shows the topics with new posts, but I can’t see how to go direct to the new posts any more.
You can find ”New posts” in the Quick links-menu when logged in.

sunbeamgls
Very active member
Very active member
Posts: 811
Joined: 2012-04-04 15:19
Location: North Wales
Contact:

Re: Forum issues are discussed here

Post by sunbeamgls » 2018-11-13 11:34

I like the new look too - its clean and easy on the eye
AEDSM; AEBox/1; 3x Tundra Stereo 2.5; PMC 20.26. Blogger. Exakt Design. SO measuring.

Sopper
Very active member
Very active member
Posts: 293
Joined: 2017-05-16 14:50
Location: The Netherlands

Re: Forum issues are discussed here

Post by Sopper » 2018-11-13 12:01

Forum doesn’t remember me, have to log in each time
# HAKAI # Sagatun mono + Tundra mono # Harbeth SHL5+ 40th Ann # Mogami Neglex III 2803 + 2804

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2018-11-13 12:23

Sopper wrote:
2018-11-13 12:01
Forum doesn’t remember me, have to log in each time
Confirmed!

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2018-11-13 13:59

Maybe fixed now?

Sopper
Very active member
Very active member
Posts: 293
Joined: 2017-05-16 14:50
Location: The Netherlands

Re: Forum issues are discussed here

Post by Sopper » 2018-11-13 14:05

lejonklou wrote:
2018-11-13 13:59
Maybe fixed now?
Yes, it seems to remember me again :)
# HAKAI # Sagatun mono + Tundra mono # Harbeth SHL5+ 40th Ann # Mogami Neglex III 2803 + 2804

matthias
Very active member
Very active member
Posts: 1021
Joined: 2007-12-25 16:47
Location: Germany

Re: Forum issues are discussed here

Post by matthias » 2018-11-13 15:03

macrotech2 wrote:
2018-11-13 09:46
I like the new look! Thanks for all the hard work Fredrik.
+1
But on the mobile version there is neither last post nor author of the last post.

Matt
LP12 / Exposure / JBL3677

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2018-11-13 15:21

matthias wrote:
2018-11-13 15:03
macrotech2 wrote:
2018-11-13 09:46
I like the new look! Thanks for all the hard work Fredrik.
+1
But on the mobile version there is neither last post nor author of the last post.

Matt
Yes, this is the number one thing I would like to fix. Spent a few hours on adjusting the layout on narrow screens, but it didn't work out well. The design is responsive, so there are several steps of change as the screen narrows and all the parameters need to synch, otherwise it becomes a mess.

I will need help from someone familiar with trimming responsive behavior on phpBB3.2.

Sopper
Very active member
Very active member
Posts: 293
Joined: 2017-05-16 14:50
Location: The Netherlands

Re: Forum issues are discussed here

Post by Sopper » 2018-11-13 18:18

iPad and iPhone warning for unsafe website and don’t remember me.
Windows explorer did remember me
# HAKAI # Sagatun mono + Tundra mono # Harbeth SHL5+ 40th Ann # Mogami Neglex III 2803 + 2804

Music at Home
Active member
Active member
Posts: 119
Joined: 2008-10-09 16:10

Re: Forum issues are discussed here

Post by Music at Home » 2018-11-13 22:09

I like the new look. Looks very clean, fresh and zesty <thumbs-up emoticon>

tokenbrit
Very active member
Very active member
Posts: 1065
Joined: 2012-03-22 19:47
Location: New England

Re: Forum issues are discussed here

Post by tokenbrit » 2018-11-13 23:12

I also like the new look .. just wish it was a bit more mobile friendly: on the phone, there's no indication at index level which threads have new posts. No problem if logged in, but phone browsing through new posts now requires a visit to each category .. unless I'm missing something.

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2018-11-13 23:54

tokenbrit wrote:
2018-11-13 23:12
I also like the new look .. just wish it was a bit more mobile friendly: on the phone, there's no indication at index level which threads have new posts. No problem if logged in, but phone browsing through new posts now requires a visit to each category .. unless I'm missing something.
Correct!

The old responsive style hid the columns Topics and Posts when the screen width was small enough. Then there was enough room for both Category and Last Post columns. In this current style, it shows only Category.

This is not a trivial thing to change, so I need the help of someone experienced to re-implement the old responsive scheme.

I'm really happy that so many seem to accept or even like the new style! I personally find the new font easy to read.

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2018-11-14 00:34

Sopper wrote:
2018-11-13 18:18
iPad and iPhone warning for unsafe website and don’t remember me.
Windows explorer did remember me
Thank you!

Server settings changed. I think that now it will always redirect to https and no warning should come.

Please report if the re-login problem persists. I don't think it will.

Charlie1
Very active member
Very active member
Posts: 3280
Joined: 2007-12-11 00:30
Location: UK

Re: Forum issues are discussed here

Post by Charlie1 » 2018-11-14 13:07

I like the new look too. Just that little bit of colour helps too.

I've not experienced any issues on Windows laptops, mac, iphones and ipad.

User avatar
DelNaja
Active Member
Active Member
Posts: 80
Joined: 2011-12-30 11:22
Location: Gothenburg, Sweden

Re: Forum issues are discussed here

Post by DelNaja » 2018-11-14 14:34

Charlie1 wrote:
2018-11-14 13:07
I like the new look too. Just that little bit of colour helps too.

I've not experienced any issues on Windows laptops, mac, iphones and ipad.
Same here, no issues on Windows 10. Nice, Fredrik!

Sopper
Very active member
Very active member
Posts: 293
Joined: 2017-05-16 14:50
Location: The Netherlands

Re: Forum issues are discussed here

Post by Sopper » 2018-11-14 16:52

lejonklou wrote:
2018-11-14 00:34
Sopper wrote:
2018-11-13 18:18
iPad and iPhone warning for unsafe website and don’t remember me.
Windows explorer did remember me
Thank you!

Server settings changed. I think that now it will always redirect to https and no warning should come.

Please report if the re-login problem persists. I don't think it will.
Working like a charm now on IPad and IPhone.
Just need bigger layout to see who posted last in threads on my iPhone.
# HAKAI # Sagatun mono + Tundra mono # Harbeth SHL5+ 40th Ann # Mogami Neglex III 2803 + 2804

matthias
Very active member
Very active member
Posts: 1021
Joined: 2007-12-25 16:47
Location: Germany

Re: Forum issues are discussed here

Post by matthias » 2018-11-14 18:35

It is perfect on iPad, on iPhone I would like to see the info under "last post" on the iPad.

Matt
LP12 / Exposure / JBL3677

bonzo
Active member
Active member
Posts: 235
Joined: 2007-02-02 02:05
Location: Stateside

Re: Forum issues are discussed here

Post by bonzo » 2019-06-05 14:34

I’m having difficulty being able to post a reply and/or create a new topic. Once I am on the forum webpage I then “login” and after doing so I know is a successful login because I see my username in the top right of screen. Then, once I select a forum category.. (it doesn’t matter which) my name is no longer in top right of screen and if I try to reply to a thread I have to log in again. I’m sure it’s probably operator error. Any suggestions please?

Thanks everyone
Jon
lp12, Keel, K Radikal, Urika, EkosSe/1 Kandid KK1/D, Tundra Mono 2 Tarandus, 242s mk2, Rel B1.

TMV
Active Member
Active Member
Posts: 73
Joined: 2007-10-01 09:16
Location: Göteborg, Sweden

Re: Forum issues are discussed here

Post by TMV » 2019-06-16 14:36

After a forum SW update a while ago I can no longer see the last posts on the Board Index page (https://www.lejonklou.com/forum/index.php). It is possible for desktop view and before the update this was also possible on my mobile (Android).
Is it possible to get this back?

User avatar
lejonklou
Administrator
Administrator
Posts: 4776
Joined: 2007-01-30 10:38
Location: Sweden
Contact:

Re: Forum issues are discussed here

Post by lejonklou » 2019-06-16 20:15

bonzo wrote:
2019-06-05 14:34
I’m having difficulty being able to post a reply and/or create a new topic. Once I am on the forum webpage I then “login” and after doing so I know is a successful login because I see my username in the top right of screen. Then, once I select a forum category.. (it doesn’t matter which) my name is no longer in top right of screen and if I try to reply to a thread I have to log in again. I’m sure it’s probably operator error. Any suggestions please?
Hello Jon!

Apologies, I missed this post of yours! Did the problem go away? This is not anything I recognize or have come across.
TMV wrote:
2019-06-16 14:36
After a forum SW update a while ago I can no longer see the last posts on the Board Index page (https://www.lejonklou.com/forum/index.php). It is possible for desktop view and before the update this was also possible on my mobile (Android).
Is it possible to get this back?
Hi TMV!

I know, I miss this too! Unfortunately, it's a bit complicated as the whole responsive design needs to be remade. As you may have read earlier in this thread, what you call "a SW update" was actually a total scrapping of the whole forum design that the previous web designers had created, due to critical updates and incompatibility issues. I had to pick a new design overnight, and add the changes and features I was able to.

Where I got stuck was this right column "Last Post". To make it stay on a more narrow screen, all the columns need to be redefined for various screen widths. I made a half-day attempt at adding it, but it totally screwed things up, so I had to revert.

So the only way that the Last Post column is getting back on the phone in portrait orientation (you still have it in landscape orientation) is if I get some help. My old web design guys have scattered to various new companies, so if I start with a new company, we'd have to start over. Which will make it a bigger project than I'd like.

Post Reply